블록

 
a) 블록 a) 블록
 

1

insert

  •  line 현재 도면 파일에 블록 또는 파일을 삽입합니다.
  • 명령행에 INSERT를 입력하고 ENTER 키를 누르면, 블록 삽입 대화 상자가 열립니다.
  • 명령행에 -INSERT를 입력하고 ENTER 키를 누르면, 명령행에 따라 실행됩니다.
    before inserting a tree block
    after inserting a tree block

명령어
:
INSERT
리본 위치
:
홈 >> 블록
단축키
:
I or INSERTURL
Option
:
 

[INSERT]
[명령:] INSERT
[명령:] 블록 삽입 지점 설정 또는 [기준점(B)/스케일(S)/X/Y/Z/회전(R)]:
포인트 또는 옵션 키워드가 필요함.
[명령:] X 스케일 계수 또는 [코너(C)/XYZ] <1.0>:
[명령:] Y 축척 비율을 입력 <X 축척 비율 같음>:
[명령:] 블록의 회전 각도 지정  <0>:
 

  •  블록 삽입
  •  명령행에 도면 파일의 경로를 입력합니다.
  •  현재 도면에 이미 삽입한 블록이 존재할 경우, 최근에 삽입한 블록 이름이 프롬프트에 기본 블록 이름으로 나타납니다.
  •  외부 도면의 그룹화 객체는 현재 도면에 익명 그룹으로 삽입됩니다.
  •  블록 이름을 입력하는 프롬프트에 물결표(~)를 입력하면 블록 삽입 대화 상자가 열립니다.
  •  DWG 또는 DXF 형식의 기존 파일을 선택하여 현재 도면에 블록으로 삽입할 수 있습니다.
     
  •  블록 삽입 지점 설정
  •  블록 또는 파일의 삽입 위치를 설정합니다.
     
  •  기준점
  •  선택한 블록의 신규 기준점을 지정합니다.
     
  •  스케일
  •  X, Y 및 Z 축을 따라 동일한 축척을 설정합니다.
     
  •  X/Y/Z
  •  X, Y 및 Z 축을 따라 축척을 각각 설정합니다.
     
  •  회전
  •  삽입할 블록의 회전 각도를 설정합니다.
     
  •  ?
  •  설정한 블록 이름과 관련 정보를 현재 도면 파일에 나열합니다.
  •  "*" 기호를 입력하고 Enter 키를 누르면 설정한 블록 이름의 전체 목록이 나타납니다.
     
 
2

block

  •  line 블록 정의 생성을 위한 객체를 선택합니다.
  • 명령행에 BLOCK를 입력하고 ENTER를 누르면, 블록 정의 대화 상자가 열리고 블록을 정의하기 위한 관련된 설정을 사용할 수 있습니다.
  • 명령행에 -BLOCK 를 입력하고 ENTER를 누르면, 시스템은 명령어 라인 다음으로 블록 정의를 생성 합니다.
    before
    after

명령어
:
BLOCK
리본 위치
:
홈 >> 블록
단축키
:
B, BMAKE or BMOD
Option
:
 

[BLOCK]
[명령:] BLOCK
[명령:] 객체 선택:
[명령:] 1개를 찾음
 

  •  신규 블록에 대한 이름
  •  블록명을 설정합니다.이름 규칙은 시스템 변수 EXTNAMES 로 결정.
  •  EXTNAMES 의 값이 1인 경우, 블록 이름은 255자 까지 설정 가능합니다.
  •  사용 가능한 문자는 A - Z, 숫자 0 - 9, 공백 및 Microsoft® Windows® 와 ZYXCAD의 미사용 특수 문자를 포함할 수 있습니다 .
    EXTNAMES 
    • 정의 테이블에 저장되어 있는 명명된 객체 이름(예: 선종류 및 도면층)에 대한 매개변수를 설정합니다.
     
    값
    0
    • 이름을 31자 길이로 제한하는14 매개변수를 사용합니다.
    • A에서 Z까지의 문자와 0에서 9까지의 숫자 그리고 달러 기호($), 밑줄(_), 하이픈(-)과 같은 특수 문자를 이름에 사용할 수 있습니다.
    1
    이름은 최대 255자까지 지정할 수 있으며, A~Z의 문자, 0~9의 숫자, 공백 및 Microsoft® Windows®와 ZYXCAD 에서 다른 목적으로 사용되지 않는 특수 문자를 사용할 수 있습니다. 
     
    형식
    Integer
    저장
    Registry
    초기값
    0
  •  만약 입력된 블록 이름이 이미 존재하는 경우, 현재 블록 정의를 갱신할지 선택할 수 있습니다.하지만 현재 블록 속성은 바뀌지 않습니다.
     
  •  기준점
  •  블록의 삽입 지점을 지정합니다.
     
  •  신규 블록에 대한 객체 선택
  •  블록 정의에 포함될 객체를 선택합니다.
     
  •  주석
  •  주석 블록 만들기
    • 신규 생성된 블록이 주석인지 아닌지 설정합니다.
     
  •  용지 공간 뷰포트의 시트에 따라 맞춥니다
    • 용지 공간 뷰포트의 블록 참조 방향이 배치 방향과 동일한지 여부를 설정합니다.
     
  • - ? - 목록
  •  명령어 라인 창에 모든 현재 블록 이름을 나열합니다.
     
  •  블록 목록
  •  블록 이름을 입력 합니다.블록에 포함된 객체의 관련 정보는 목록에 표시됩니다.
     
  •  * 전부
  •  목록 상의 모든 블록 명을 표시합니다
     
 
3

refedit

  •  line 참조를 현재 공간에서 편집합니다.
  • Xref를 편집하면 현재 도면에서 참조를 수정하거나 블록 또는 Xref가 위치한 파일 없이 블록 정의를 다시 정의할 수 있습니다.
  • 명령행에 REFEDIT를 입력하고, 참조 대상 객체들을 선택하면 외부 참조 편집대화상자가 열립니다.
  • 명령행에 -REFEDIT를 입력하고 ENTER를 누르면, 명령행에 따라 시스템이 실행됩니다.
    before
    after

명령어
:
REFEDIT
리본 위치
:
홈 >> 블록
단축키
:
REFEDIT
Option
:
 

[REFEDIT]
[명령:] REFEDIT
[명령:] 참조 객체 선택:
[명령:] REFCLOSE
[명령:] 옵션을 입력하십시오 [저장(S)/참조 변경 취소(D)] <저장>. s
[명령:] 1개의 블록 복제가 업데이트되었습니다.ㅠ
 
[명령:] r1이(가) 재정의되었습니다.
r1은 block 예제에서 사용된 block 이름입니다.

  •  참조 객체
  •  편집할 외부 참조 또는 블록을 선택합니다.
  •  편집 중인 선택된 객체는 작업 세트로 구성됩니다.수정된 참조를 저장할 때 참조 도면을 열거나 블록을 다시 작성할 필요가 없습니다.
  •  REFEDIT 세션이 활성화된 동안, 현재 도면의 작업 설정 내 객체들을 제외한 모든 객체들이 페이딩 상태로 표시됩니다.
  •  시스템 변수 XFADECTL은 REFEDIT 세션이 활성화된 동안 다른 객체의 페이딩 표시를 설정합니다.
    • XFADECTL
      • 내부 편집 중인 참조의 밝기 강도 백분율을 조정합니다. 유효한 값의 범위는 0에서 90까지입니다.
    •  
    • 형식
      Integer
      저장
      Registry
      초기값
      50
     
  •  중첩 정도 선택
  •  현재 선택한 외부 참조의 이름 또는 블록을 표시합니다.
     
  •  예
  •  선택한 참조 또는 블록을 편집합니다.
     
  •  다음
  •  다음 사용 가능한 참조 및 중첩 참조 대상을 선택합니다.
  •  참조 대상과 중첩 참조 대상을 통해 순환하려면 다음 옵션을 사용합니다
     
 
4

attdef

  •  line 속성 정의를 설정 합니다.
  • 블록 생성 시, 속성은 블록에 밀접하게 연결된 문자 정보를 참조합니다.
  • 속성을 정의한 이후, 블록을 삽입할 때 속성 특성과 프롬프트 정보를 지정할 수 있습니다.
  • 이러한 속성 값은 동일한 문자 스타일과 문자 정렬 기능과 함께 블록을 기준으로 동일 위치에 표시됩니다.
  • 작업이 완료되면 속성 태그가 현재 도면에 표시됩니다.
  • BLOCK 작업은 블록 정의에 속성 태그를 포함합니다.태그 표시를 원하지 않는 경우,
  • 블록 정의 대화 상자에서 설정할 수 있습니다.
  • 명령행에 ATTDEF를 입력하고 ENTER를 누르면, 속성 정의 대화 상자가 열립니다.
     
  • 명령행에 -ATTDEF를 입력하고 ENTER를 누르면 다음의 프롬프트가 표시됩니다.
    block ▶️
    attdef ▶️
    insert ▶️
    insert tag
    after

명령어
:
ATTDEF
리본 위치
:
홈 >> 블록
단축키
:
att or ddattdef
Option
:
 

[ATTDEF]
[명령:] ATTDEF
[명령:] 삽입점 지정:

  •  참조 객체
  •  편집할 외부 참조 또는 블록을 선택합니다.
     
  •  편집 중인 선택된 객체는 작업 세트로 구성됩니다.
     
  •  수정된 참조를 저장할 때 참조 도면을 열거나 블록을 다시 작성할 필요가 없습니다.
     
  •  REFEDIT 세션이 활성화된 동안, 현재 도면의 작업 설정 내 객체들을 제외한 모든 객체들이 페이딩 상태로 표시됩니다.
     
  •  시스템 변수 XFADECTL은 REFEDIT 세션이 활성화된 동안 다른 객체의 페이딩 표시를 설정합니다.
     
  •  중첩 정도 선택
  •  현재 선택한 외부 참조의 이름 또는 블록을 표시합니다.
     
  •  예
  •  선택한 참조 또는 블록을 편집합니다.
     
  •  다음
  •  다음 사용 가능한 참조 및 중첩 참조 대상을 선택합니다.
     
  •  참조 대상과 중첩 참조 대상을 통해 순환하려면 다음 옵션을 사용합니다
     
 
5

CopyBase

  •  line 기준점과 함께 객체를 복사하고 선택한 객체의 복제 위치를 정확하게 지정합니다.
     
  • 복사할 객체와 기준점을 선택한 후에는 선택한 객체가 이미 클립 보드에 복사되어 있습니다.
  • PASTECLIP 명령을 사용하면, 복사된 객체는 클립 보드로부터 동일한 파일 또는 다른 파일에서 선택된 객체와 동일한 위치로 복사됩니다.
  • 붙여넣기 하는 동안, 붙여넣을 객체가 COPYBASE 명령으로 복사된 객체이면 시스템은 지정된 기준점의 위치를 기준으로 그것을 붙여넣습니다.
     
    before
    after

명령어
:
COPYBASE
리본 위치
:
메뉴: 편집 » 기준점을 사용하여 복사
단축키
:
 
Option
:
 

COPYBASE
[명령:] COPYBASE
[명령:] 기준점 선택:
1개를 찾음
 
[명령:]: PASTECLIP
블록 RD100의 중복 정의를 무시하십시오.
블록 A$C13952BEC의 중복 정의를 무시하십시오.
블록 A$C37F57B18의 중복 정의를 무시하십시오.
.
.
삽입점 지정: 40000,20000

  • 기준점 선택
     
  • 도면 영역에서 점을 지정합니다.
     
  • 클립보드에 복사합니다.
     
  • 클립보드에 복사할 객체를 지정합니다.
     

  • 클립보드로 객체 잘라내기
     
  • 잘라내려는 객체를 선택합니다.
  • 홈 탭 » 클립보드 패널 » 자르기를 클릭합니다.Ctrl+X를 누를 수 있습니다.
  • 객체를 다른 Windows 응용프로그램으로 붙여넣을 수 있습니다.
     
  • 클립보드로 객체 복사하기
     
  • 복사하려는 객체를 선택합니다.
  • 홈 탭 » 클립보드 패널 » 복사를 클릭합니다.Ctrl+C를 누를 수 있습니다.
     
  • 클립보드의 객체 붙여넣기
     
  • 홈 탭 » 클립보드 패널 » 붙여넣기를 클릭합니다.Ctrl+V를 누를 수 있습니다.
  • 현재 클립보드에 있는 객체가 도면으로 붙여넣기됩니다.
     
  • 붙여넣은 정보를 ZYXCAD Ax형식으로 변환하기
     
  • 홈 탭 » 클립보드 패널 » 선택하여 붙여넣기를 클릭합니다.
  • 선택하여 붙여넣기 대화상자에서 붙여넣기를 선택합니다.
  • 형식 목록에서 그림을 선택합니다.
  • 확인을 클릭합니다.
     
6

ChangeBase

  •  line 도면에서 블록의 기준점을 변경합니다.
     
    before
    after

명령어
:
CHANGEBASE
리본 위치
:
리본 (2D): 홈 » 블록 » 블록 기준점 변경 또는 삽입 » 블록 » 블록 기준점 변경
리본 (3D): 삽입 » 블록 » 블록 기준점 변경
메뉴: 그리기 » 블록 » 블록 기준점 변경
단축키
:
CB
Option
:
 

CHANGEBASE
[명령:] COPYBASE
[명령:] 기준점 선택:
1개를 찾음
 
[명령:]: PASTECLIP
블록 RD100의 중복 정의를 무시하십시오.
블록 A$C13952BEC의 중복 정의를 무시하십시오.
블록 A$C37F57B18의 중복 정의를 무시하십시오.
.
.
삽입점 지정: 40000,20000

  • 기준점을 변경할 블록 선택
  • 도면 영역에서 기준점을 수정할 블록 참조를 선택합니다.
     
  • 기준점의 새 위치 지정
  • 새 기준점의 위치를 지정하고 점 좌표를 입력하거나 도면 영역에 점을 지정합니다.
     
  • 기준점 이동 모드 지정
  • 기준점을 변경한 후 블록 참조를 이동할지 여부를 지정합니다.
     
  • 객체 이동
  • 기준점을 변경하고 블록 참조를 이동하여 새 기준점을 원래 기준점과 맞춥니다.
     
  • 기준점 이동
  • 블록 참조를 이동하지 않고 기준점을 새 위치로 설정합니다.
     
     
7

OleLinks

  •  line 기존의 OLE 링크에 대한 다른 연산들을 변경, 취소 혹은 실행합니다.
  • 이 명령어로 연결 대화상자가 열릴 것이며, 이 상자를 통해, 도면 파일에 포함된 OLE 링크들에 대한 다른 연산들을 업데이트, 변경, 중단 혹은 실행할 수 있습니다.만일 현재 도면 내 OLE 링크가 존재하지 않는다면, 링크의 목록은 비어있게 됩니다.
     
    OleLinks

명령어
:
OLELINKS
리본 위치
:
Command
단축키
:
 
Option
:
 

OLELINKS
[명령:] OLELINKS
 
 
 
8

BTestBlock

  •  line 플렉시 블록을 테스트하려면 블록 테스트 창에서 현재 블록 정의를 엽니다.
  • "블록 테스트 창"에서 블록 편집기를 닫지 않고 블록을 테스트 할 수 있습니다.
         BTESTBLOCK 명령은 블록 편집기에서만 사용할 수 있습니다.BEDIT 명령어는 "블록 테스트 창"에서 사용할 수 없습니다.
     

명령어
:
BTESTBLOCK
리본 위치
:
리본: 블록 편집기 상황 탭 » 열기/저장 » 테스트 블록
단축키
:
 
Option
:
 

BTESTBLOCK
[명령:] BTESTBLOCK

 
 
9

DDATTE

  •  line블록의 모든 속성 정보를 편집합니다.
     
  • 명령행에 DDATTE를 입력하고 ENTER를 누릅니다.
  • 속성이 있는 블록을 선택하면, 블록 속성 편집 대화 상자가 열립니다.
  • 대화 상자에서 블록의 속성 값을 수정할 수 있습니다.

명령어
:
DDATTE
리본 위치
:
 
단축키
:
command
Option
: