[ZYXCAD Ax 2026]
 
×

삽입-블록

 
 
C. 삽입-블록
1

삽입

  •  line 현재 도면 파일에 블록 또는 파일을 삽입합니다.
  • 명령행에 INSERT를 입력하고 ENTER 키를 누르면, 블록 삽입 대화 상자가 열립니다.
  • 명령행에 -INSERT를 입력하고 ENTER 키를 누르면, 명령행에 따라 실행됩니다.
    before inserting a tree block
    after inserting a tree block

명령어
:
INSERT
리본 위치
:
삽입 >> 블록
단축키
:
I or INSERTURL
Option
:
 

[INSERT]
[명령:] INSERT
[명령:] 블록 삽입 지점 설정 또는 [기준점(B)/스케일(S)/X/Y/Z/회전(R)]:
포인트 또는 옵션 키워드가 필요함.
[명령:] X 스케일 계수 또는 [코너(C)/XYZ] <1.0>:
[명령:] Y 축척 비율을 입력 <X 축척 비율 같음>:
[명령:] 블록의 회전 각도 지정  <0>:
 

  • - 블록 삽입
  •  명령행에 도면 파일의 경로를 입력합니다.
  •  현재 도면에 이미 삽입한 블록이 존재할 경우, 최근에 삽입한 블록 이름이 프롬프트에 기본 블록 이름으로 나타납니다.
  •  외부 도면의 그룹화 객체는 현재 도면에 익명 그룹으로 삽입됩니다.
  •  블록 이름을 입력하는 프롬프트에 물결표(~)를 입력하면 블록 삽입 대화 상자가 열립니다.
  •  DWG 또는 DXF 형식의 기존 파일을 선택하여 현재 도면에 블록으로 삽입할 수 있습니다.
     
  • - 블록 삽입 지점 설정
  •  블록 또는 파일의 삽입 위치를 설정합니다.
     
  • - 기준점
  •  선택한 블록의 신규 기준점을 지정합니다.
     
  • - 스케일
  •  X, Y 및 Z 축을 따라 동일한 축척을 설정합니다.
     
  • - X/Y/Z
  •  X, Y 및 Z 축을 따라 축척을 각각 설정합니다.
     
  • - 회전
  •  삽입할 블록의 회전 각도를 설정합니다.
     
  • - ?
  •  설정한 블록 이름과 관련 정보를 현재 도면 파일에 나열합니다.
  •  "*" 기호를 입력하고 Enter 키를 누르면 설정한 블록 이름의 전체 목록이 나타납니다.
     
 
2

생성

  •  line 블록 정의 생성을 위한 객체를 선택합니다.
  • 명령행에 BLOCK를 입력하고 ENTER를 누르면, 블록 정의 대화 상자가 열리고 블록을 정의하기 위한 관련된 설정을 사용할 수 있습니다.
  • 명령행에 -BLOCK 를 입력하고 ENTER를 누르면, 시스템은 명령어 라인 다음으로 블록 정의를 생성 합니다.
    before
    after

명령어
:
BLOCK
리본 위치
:
삽입 >> 블록
단축키
:
B, BMAKE or BMOD
Option
:
 

[BLOCK]
[명령:] BLOCK
[명령:] 객체 선택:
[명령:] 1개를 찾음
 

  • - 신규 블록에 대한 이름
  •  블록명을 설정합니다.
  •  이름 규칙은 시스템 변수 EXTNAMES로 결정. EXTNAMES 의 값이 1인 경우, 블록 이름은 255자 까지 설정 가능, 사용 가능한 문자는 A - Z, 숫자 0 - 9, 공백 및 Microsoft® Windows® 와 ZYXCAD의 미사용 특수 문자를 포함
  •  만약 입력된 블록 이름이 이미 존재하는 경우, 현재 블록 정의를 갱신할지 선택할 수 있습니다.하지만 현재 블록 속성은 바뀌지 않습니다.
     
  •  기준점
  •  블록의 삽입 지점을 지정합니다.
     
  •  신규 블록에 대한 객체 선택
  •  블록 정의에 포함될 객체를 선택합니다.
     
  •  주석
  •  주석 블록 만들기
    • 신규 생성된 블록이 주석인지 아닌지 설정합니다.
     
  •  용지 공간 뷰포트의 시트에 따라 맞춥니다
  • • 용지 공간 뷰포트의 블록 참조 방향이 배치 방향과 동일한지 여부를 설정합니다.
     
  • - 목록
  •  명령어 라인 창에 모든 현재 블록 이름을 나열합니다.
     
  • - 블록 목록
  •  블록 이름을 입력 합니다.블록에 포함된 객체의 관련 정보는 목록에 표시됩니다.
     
  • - * 전부
  •  목록 상의 모든 블록 명을 표시합니다
     
 
3

블럭 내보내기

  •  line 객체 또는 블록을 새로운 도면 파일에 저장합니다.
  • 명령창에 WBLOCK을 입력하고 ENTER를 누르면 블록을 블록 내보내기 대화 상자가 열린다.
  • 만일 시스템 변수 FILEDIA 이 1로 설정되어 있으면, 명령창에 -WBLOCK을 입력하면 블록 저장 대화 상자가 열리며, 그 안에서 사용자는 새로운 도면 파일의 이름과 저장 경로를 지정할 수 있습니다.
  • 만일 시스템 변수 FILEDIA 이 0으로 설정되어 있을 경우, 명령창에 -WBLOCK을 입력하면 다음과 같은 프롬프트가 표시됩니다.
     

명령어
:
WBLOCK
리본 위치
:
삽입>> 참조
단축키
:
W

 
  • - Wblock의 파일 이름 입력
  •  출력 파일의 이름을 지정합니다.
     
  • - 기존의 블록 이름 입력
  •  기존의 블록 이름을 입력하고 그것을 출력 파일에 저장합니다.
     
  • - & (다중 블록 포함)
  •  "&"을 입력하고 ENTER를 누르고, 다시 블록 이름을 입력하여 지정한 블록을 출력 파일에 저장합니다.
     
  • - * (전체 도면)
  •  "*"를 입력하고 ENTER를 눌러 현재의 도면 내의모든 객체를 출력 파일에 저장합니다 .
  •  그 안으로, 모형 공간 내와 종이 공간 내의 객체가 각각 모형 공간 및 배치 공간에 저장됩니다.
     
  • - 객체 선택
  •  ENTER를 눌러 기준점을 지정하고 출력 파일에 기록할 하나 이상의 객체를 선택합니다.
     
 
4

기준점

  •  line 현재 도면을 다른 파일에 삽입 시 기준점을 지정합니다.
  • BASE 명령어로, 현재 도면을 다른 도면으로 삽입 또는 외부에서 참조할 시, (0.0000,0.0000,0.0000) 을 제외한 다른 지점이 삽입 기준점으로 지정 될 수 있습니다.
  • 기준점 값은 시스템 변수 INSBASE에 저장되며, 현재 UCS의 좌표 값을 사용해야 합니다.
    INSBASE
    • BASE 로 설정한 삽입 기준점을 저장합니다.
    •  이는 현재 공간에 대한 UCS 좌표로 표현됩니다.
     
    형식
    3D Point
    저장
    DWG
    초기값
     0.0000, 0.0000, 0.0000
     

명령어
:
BASE
리본 위치
:
삽입>> 참조
단축키
:
 

 
◎ 기준점 지정
 
  •    정확한 좌표 값을 입력하거나 도면 영역에 점을 지정합니다.
     
5

블럭 편집기

  •  line 블록 편집기 내에 지정된 블록 정의 열기
  • 블록 정의 편집 대화상자를 열기 위해 명령어 라인에 BEDIT를 입력하고 ENTER를 누릅니다.
  • 블록 편집기에서 편집될 목록으로 부터 하나의 정의 이름을 선택할 수 있으며, 또는 편집기에서 생성될 정의의 이름을 입력할 수 있습니다.
    도면 영역에서 어느 블록 정의라도 더블클릭하여 블록 정의 편집 대화 상자를 열 수 있습니다.
     
  • 명령행으로 프롬프트 하기 위해 -BEDIT 을 입력하고 ENTER를 누릅니다.
     

명령어
:
BEDIT
리본 위치
:
삽입>> 참조
단축키
:
 

 
- 신규 블록에 대한 이름
  •  현재 블록 정의 또는 생성될 블록 정의에 대한 이름을 입력합니다.
     
    - 목록
  •  현재 도면에 모든 블록 정의를 나열합니다.
  •  전체 목록을 표시하려면 별표(*)를 입력합니다.
     
 
6

oleopen

  • 선택된 OLE 객체에 대한 소스 파일을 열거나 이 OLE 객체 내용에 포함된 새 파일을 엽니다.
  • 선택된 OLE 객체를 링크 객체로서 현재의 도면에 삽입할 때, OLEOPEN 명령어를 실행하면 이 OLE 객체에 포함된 링크가 지정하는 소스 파일이 열립니다.
  • 선택된 OLE 객체를 포함 객체로서 현재의 도면에 삽입할 때, OLEOPEN 명령어를 실행하면 이 OLE 객체 내용이 포함된 새 파일이 열립니다.
  • 만일 현재 도면 내 OLE 링크가 존재하지 않거나 OLE 객체가 선택되지 않는 경우, 이 명령어를 시행할 때 에러 메시지가 표시됩니다.
     

명령어
:
OLEOPEN
리본 위치
:
삽입>> 참조
단축키
:
 

 
 
7

minsert

 
  •  line 설정된 블록의 여러 복사본을 삽입하여 직사각형 배열을 생성합니다.
     
  • 복사본은 설정한 점을 기준으로 배열됩니다.
  • MINSERT 명령으로 삽입된 블록은 분해할 수 없습니다.
     
    before
    after
 

명령어
:
MINSERT
리본 위치
:
 
단축키
:
command

MINSERT
[명령:] MINSERT
 
삽입할 블록의 이름 입력 또는 [?] <b1>:
 
블록 삽입 지점 설정 또는 [기준점(B)/스케일(S)/X/Y/Z/회전(R)]:
X 스케일 계수 또는 [코너(C)/XYZ] <1.0>:
 
Y 축척 비율을 입력 <X 축척 비율 같음>:
 
블록의 회전 각도 지정 <0>:
 
행의 수 입력 <1>: 2
 
열의 수 입력 <1>: 2
 
열 간의 수직 거리 또는 벌어진 직사각형의 간격:
반대 구석 지정:

 
  • 블록의 이름
     
  • 블록 이름을 입력합니다.블록 이름의 입력은 기본적으로 INSERT 명령으로 소개된 것과 동일합니다.
    블록 이름 앞에 별표(*)를 사용하여 블록 객체를 폭파할 수 없으며, 이는 INSERT로 할 수 있다.
     
  • 블록 삽입
     
  • 현재 도면 파일에 설정된 블록 또는 파일을 삽입합니다.
     
  • 블록의 삽입점
     
  • 블록 또는 파일의 삽입점을 설정합니다.
     
  • X 축척 계수
     
  • X 및 Y 축척 계수를 설정합니다.
     
  • 블록의 회전 각도
     
  • 단일 블록을 삽입하기 위한 회전 각도를 설정합니다.이 각도는 전체 배열의 각도입니다.
     
  • 행의/열의 수
     
  • 배열에서 행과 열의 개수를 설정합니다.
     
  • 행 사이 수직 거리
     
  • 마우스를 클릭하여 행 사이의 거리를 설정하거나, 도면 영역에서 직사각형에 대해 두 개의 대각선 점을 설정합니다.
  • 그 길이는 수직 거리와, 수평 거리에 대한 폭을 나타냅니다.
     
  • 열 사이 수평 거리
     
  • 열 사이의 거리를 설정합니다.
     
  • 코너
     
  • 블록 삽입 점과 반대 코너를 설정하여 축척 계수를 설정합니다.
     
  • XYZ
     
  • X, Y 및 Z 축척 계수를 별도로 설정합니다.
     
  • 기준점
     
  • 블록 또는 파일을 삽입할 기준점을 설정합니다.
     
  • 축척
     
  • 블록 또는 파일을 삽입할 XYZ의 축척 계수를 설정합니다.
     
  • X, Y, Z
     
  • 블록이나 파일을 삽입하기 위해 X 축, Y 축 및 Z 축의 축척 계수를 별도로 설정합니다.
     
  • 회전
     
  • 블록 또는 파일을 삽입할 회전 각도를 설정합니다.
     
  • ? - 목록
     
  • 정의된 블록 이름과 그 관련 정보를 현재 도면 파일에 나열합니다.
 
 

  • 현재 도면에 정의된 블록 삽입하기
 
  • 삽입 탭 » 블록 패널 » 삽입을 클릭합니다.
  • 삽입 대화상자의 이름 상자에서 블록 정의 목록으로부터 이름을 선택합니다.
  • 포인팅 장치를 사용하여 도면 영역에서 삽입점, 축척 및 회전 각도를 지정하려면 화면에서 지정을 선택해 주십시오.그렇지 않으면 삽입점, 축척 및 회전 상자에 값을 입력하십시오.
  • 하나의 블록 대신 블록을 포함한 객체들을 개별적으로 삽입하려면 분해를 선택하십시오.
  • 삽입을 클릭합니다.
     
  • 끌어놓기를 통해 도면 파일을 블록으로 삽입하기
 
  • Windows 탐색기 또는 임의의 폴더에서 도면 파일 아이콘을 도면 영역으로 끌어놓습니다.
  • 마우스 버튼을 해제한 후 프롬프트가 뜨면 삽입점을 지정합니다.
  •  
  • 삽입점, 축척 비율 및 회전 각도를 지정합니다.
     
  • 디자인 센터에서 블록 삽입하기
 
  • 도구 탭 » 팔레트 패널 » 디자인 센터를 클릭합니다.
  • 폴더 탭의 트리 다이아그램에서 삽입할 블록이 들어 있는 그래픽 파일로 이동합니다.
  • 그래픽 목록을 펼쳐서 블록 아이콘을 클릭합니다.그래픽 파일에 포함된 블록 정의가 오른쪽에 표시됩니다.
  • 다음 중 한 가지를 수행합니다:
  • 삽입하려는 블록을 두 번 클릭합니다.
  • 삽입하려는 블록을 선택하고 삽입하려는 도면 파일로 블록을 끌어놓습니다.
8

bycleorder

  •  line 플렉시 블록 정의에서 그립의 순환 순서를 설정합니다.
  • 블록 편집기에 BCYCLEORDER 명령을 입력하여 삽입 순환 순서 대화 상자를 엽니다.
  • 도면에 플렉시 블록 참조를 삽입할 때 그립 간 순환에 CTRL 키를 이용할 수 있으며, 이때 선택한 그립이 삽입점으로 이용됩니다.
     

명령어
:
BCYCLEORDER
리본 위치
:
command
단축키
:
 

 
 
9

bparameter

  •  line블록 편집기에서 그립이 있는 매개 변수를 플렉시 블록 정의로 추가합니다.
     
  • BPARAMETER 명령은 블록 편집기에서 플렉시 블록 참조의 사용자 정의 특성을 정의하려는 경우에만 사용할 수 있습니다.
  • 추가된 매개 변수를 플렉시 블록을 정의할 작업과 연결합니다.
  • 플렉시 블록 정의에 매개 변수를 추가하고 나면, 플렉시 블록 참조를 조작할 때 매개 변수의 일부가 되는 매개 변수의 주요 지점에 그립이 표시됩니다.
  • 매개 변수에 대한 Parameter 편집은 Baction-parameter를 참고 하세요.
        
     

명령어
:
BPARAMETER
리본 위치
:
command
단축키
:
 

 
 
10

bgriset

  •  line지정된 매개 변수와 연결된 그립 수를 수정하거나 그립의 위치를 복원합니다.
     

명령어
:
BGRIPSET
리본 위치
:
command
단축키
:
 

  • 매개 변수 선택
     
  • 현재 블록 정의에서 매개 변수를 선택합니다.선택된 매개 변수에 연결된 그립의 숫자 또는 위치는 변경됩니다.
     
  • 매개 변수에 대한 그립 객체 수 입력
     
  • 선택된 매개 변수에 연결된 그립 객체의 숫자 지정.
     
  • 사용할 수 있는 그립 객체의 수는 선택한 매개 변수의 유형에 따라 다릅니다.
     
  • 위치 변경
     
  • 그립을 기본 위치로 복원합니다.
     
     
11

bconvert

  •  line 현재 도면에서 지정한 동적 블록을 플렉시 블록으로 전환합니다.
  • 명령행에 BCONVERT를 입력하고 Enter 키를 눌러 블록 변환 대화 상자를 엽니다.
  • 명령행에 -BCONVERT를 입력하고 Enter를 누르면 명령행에 프롬프트가 나타납니다.
    ZYXCAD Ax에서는 동적 블록을 바로 편집할 수 없습니다. 동적 블록을 편집하려면 플렉시 블록으로 먼저 변환해야 합니다.
     

    명령어
    :
    BCONVERT
    리본 위치
    :
    command
    단축키
    :
     
 

  • 동적 블록 이름을 입력
     
  • 현재 도면에서 변환할 동적 블록의 이름을 입력합니다.
     
  • ? - 리스트
     
  • 현재 도면의 모든 동적 블록 이름을 나열합니다.
     
  • 블록 정의 설정
     
  • 동적 블록 정의를 유지할지 여부를 지정합니다.
     
  • 블록 정의 재정의
     
  • 변환된 플렉시 블록 정의가 동적 블록 정의를 대체합니다.
     
  • 새 블록 정의 생성
     
  • 동적 블록 정의는 유지되고, 변환된 플렉시 블록 정의의 이름을 변경합니다.
     
  • 변환된 블록 이름 입력
     
  • 변환된 플렉시 블록 이름을 입력합니다.
     
  • 블록 참조 설정
     
  • 모든 동적 블록 참조를 대체할지 여부를 지정합니다.
     
  • 모든 블록 참조 바꿈
     
  • 현재 도면의 모든 동적 블록 참조를 변환된 플렉시 블록 참조로 대체합니다.
     
  • 대체할 블록 참조 지정
     
  • 도면 영역에서 대체할 동적 블록 참조를 선택합니다.